Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] The Source Code → Error Compile ( Windows 8 with visual studio 2015 )

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 6

1

Topic: Error Compile ( Windows 8 with visual studio 2015 )

Hello harpywar,
This is a picture of my screenshot for error when using magic builder :

http://forums.harpywar.com/extensions/hcs_image_uploader/uploads/0/7000/7343/thumb/p1a5ogfccs17ac19ll14bq329pb31.png

i already re-install visual studio 2015 up to 3x
please help

i confused for this error ( line : 10 on source "CMakelists" )

+ show spoiler

# Required cmake version
cmake_minimum_required(VERSION 3.1.0)

# Put the include dirs which are in the source or build tree
# before all other include dirs, so the headers in the sources
# are prefered over the already installed ones
# since cmake 2.4.1
set(CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE ON)

project(pvpgn CXX)

option(WITH_BNETD "compile the bnetd target" ON)
option(WITH_D2CS "compile the d2cs target" ON)
option(WITH_D2DBS "compile the d2dbs target" ON)
option(WITH_LUA "enable Lua support" OFF)
if(WIN32)
    option(WITH_WIN32_GUI "enable GUI building (default on)" ON)
endif(WIN32)

#storage backends flags
option(WITH_MYSQL "include MySQL user accounts support" OFF)
option(WITH_SQLITE3 "include SQLite3 user accounts support" OFF)
option(WITH_PGSQL "include PostgreSQL user accounts support" OFF)
option(WITH_ODBC "include ODBC user accounts support" OFF)
include(ConfigureChecks.cmake)


if (CMAKE_COMPILER_IS_GNUCXX)
    # Minimum G++ version: 5.1
    if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.1)
        message(FATAL_ERROR "G++ 5.1 or higher required")
    endif()

    set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -pedantic -Wno-variadic-macros")
 
    # Pass CXX flags to flags.
    set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSEQAN_CXX_FLAGS_=\"${CMAKE_CXX_FLAGS}\"")
endif ()

if (MSVC)
    # cl.exe version
    if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 19.0)
        message(FATAL_ERROR "Visual Studio 2015 or higher required")
    endif()
endif ()

if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
       set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -pedantic")
 
       # Pass CXX flags to flags.
       set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSEQAN_CXX_FLAGS_=\"${CMAKE_CXX_FLAGS}\"")
endif()

subdirs(src conf man files)
if(WITH_LUA)
    add_subdirectory(lua)
endif(WITH_LUA)

ENABLE_TESTING()

# uninstall target
configure_file(
    "${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
    "${CMAKE_MODULE_PATH}/cmake_uninstall.cmake"
    IMMEDIATE @ONLY)

add_custom_target(uninstall
    COMMAND ${CMAKE_COMMAND} -P ${CMAKE_MODULE_PATH}/cmake_uninstall.cmake)
   
# purge target
configure_file(
    "${CMAKE_MODULE_PATH}/cmake_purge.cmake.in"
    "${CMAKE_MODULE_PATH}/cmake_purge.cmake"
    IMMEDIATE @ONLY)

add_custom_target(purge
    COMMAND ${CMAKE_COMMAND} -P ${CMAKE_MODULE_PATH}/cmake_purge.cmake)

thanks,

2

Re: Error Compile ( Windows 8 with visual studio 2015 )

I get the same error on my system after an update.
I will look into this issue as soon as possible and add update here.

Now you can download automated windows builds from http://pvpgn.pro/

Do not ask for support in PM.

3

Re: Error Compile ( Windows 8 with visual studio 2015 )

HarpyWar wrote:

I get the same error on my system after an update.
I will look into this issue as soon as possible and add update here.

Now you can download automated windows builds from http://pvpgn.pro/

I almost completed the project pvpgn it to completion, but a lot of errors and crashes in previous versions
and did not continue for project pvpgn, and use pvpgn version 1.99 SVN
Thanks Harpywar

4 (edited by Dante 24.03.2016 09:46)

Re: Error Compile ( Windows 8 with visual studio 2015 )

vallcerealz wrote:

Hello harpywar,
This is a picture of my screenshot for error when using magic builder :

http://forums.harpywar.com/extensions/hcs_image_uploader/uploads/0/7000/7343/thumb/p1a5ogfccs17ac19ll14bq329pb31.png

i already re-install visual studio 2015 up to 3x
please help

i confused for this error ( line : 10 on source "CMakelists" )

+ show spoiler

# Required cmake version
cmake_minimum_required(VERSION 3.1.0)

# Put the include dirs which are in the source or build tree
# before all other include dirs, so the headers in the sources
# are prefered over the already installed ones
# since cmake 2.4.1
set(CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE ON)

project(pvpgn CXX)

option(WITH_BNETD "compile the bnetd target" ON)
option(WITH_D2CS "compile the d2cs target" ON)
option(WITH_D2DBS "compile the d2dbs target" ON)
option(WITH_LUA "enable Lua support" OFF)
if(WIN32)
    option(WITH_WIN32_GUI "enable GUI building (default on)" ON)
endif(WIN32)

#storage backends flags
option(WITH_MYSQL "include MySQL user accounts support" OFF)
option(WITH_SQLITE3 "include SQLite3 user accounts support" OFF)
option(WITH_PGSQL "include PostgreSQL user accounts support" OFF)
option(WITH_ODBC "include ODBC user accounts support" OFF)
include(ConfigureChecks.cmake)


if (CMAKE_COMPILER_IS_GNUCXX)
    # Minimum G++ version: 5.1
    if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.1)
        message(FATAL_ERROR "G++ 5.1 or higher required")
    endif()

    set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -pedantic -Wno-variadic-macros")
 
    # Pass CXX flags to flags.
    set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSEQAN_CXX_FLAGS_=\"${CMAKE_CXX_FLAGS}\"")
endif ()

if (MSVC)
    # cl.exe version
    if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 19.0)
        message(FATAL_ERROR "Visual Studio 2015 or higher required")
    endif()
endif ()

if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
       set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -pedantic")
 
       # Pass CXX flags to flags.
       set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSEQAN_CXX_FLAGS_=\"${CMAKE_CXX_FLAGS}\"")
endif()

subdirs(src conf man files)
if(WITH_LUA)
    add_subdirectory(lua)
endif(WITH_LUA)

ENABLE_TESTING()

# uninstall target
configure_file(
    "${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
    "${CMAKE_MODULE_PATH}/cmake_uninstall.cmake"
    IMMEDIATE @ONLY)

add_custom_target(uninstall
    COMMAND ${CMAKE_COMMAND} -P ${CMAKE_MODULE_PATH}/cmake_uninstall.cmake)
   
# purge target
configure_file(
    "${CMAKE_MODULE_PATH}/cmake_purge.cmake.in"
    "${CMAKE_MODULE_PATH}/cmake_purge.cmake"
    IMMEDIATE @ONLY)

add_custom_target(purge
    COMMAND ${CMAKE_COMMAND} -P ${CMAKE_MODULE_PATH}/cmake_purge.cmake)

thanks,

upgrade visual studio 2015
install complement c++

pvpgn-magical builder working in win10,64bits

Post's attachments

Attachment icon working.png 85.45 kb, 56 downloads since 2016-03-24 

5

Re: Error Compile ( Windows 8 with visual studio 2015 )

I've found some time to investigate the issue.
It was just because Visual Studio 2015 doesn't install C++ by default. You have to rerun the setup, select Modify and then check Programming Language -> C++.

Add this info to readme https://github.com/pvpgn/pvpgn-magic-builder

UPD
It seems Dante wrote about the same in the post before.

Do not ask for support in PM.

6

Re: Error Compile ( Windows 8 with visual studio 2015 )

HarpyWar wrote:

I've found some time to investigate the issue.
It was just because Visual Studio 2015 doesn't install C++ by default. You have to rerun the setup, select Modify and then check Programming Language -> C++.

Add this info to readme https://github.com/pvpgn/pvpgn-magic-builder

UPD
It seems Dante wrote about the same in the post before.

It is now available visual studio 2015 with c ++ addons

download https://www.visualstudio.com/en-us/down … io-vs.aspx

Posts: 6

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] The Source Code → Error Compile ( Windows 8 with visual studio 2015 )



Generated in 0.201 seconds (45% PHP - 55% DB) with 20 queries