Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Diablo → D2GS DROP PROBLEM

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 12

1 (edited by blackwolf 10.07.2016 02:47)

Topic: D2GS DROP PROBLEM

I do not know what is happening, already tried to install all versions of D2GS (Magic-builder) and is the same mistake, even starting only he, after a few seconds it closes and generates the LOG's (below).

So I thought that the problem was on my computer, I installed Visual Studio 2015 C ++ complete, the D2GS returned to work, but after a few hours returned the error and stopped start, without any modified file.

What can it be?
Attack on my server?
compatibility issue (start all in "Win XP service pack 3")?
Some configuration? Please help me ... = /

LOG FILES BELOW

Post's attachments

Attachment icon LOGS.txt 61.49 kb, 113 downloads since 2016-07-10 

2

Re: D2GS DROP PROBLEM

As I can see from logs you are using multithreaded D2GS that can be run only with modified d2cs from the repo https://github.com/tesseract2048/pvpgn.
Also this D2GS has different settings in the Windows registry unlike default D2GS.

Do not ask for support in PM.

3

Re: D2GS DROP PROBLEM

HarpyWar wrote:

As I can see from logs you are using multithreaded D2GS that can be run only with modified d2cs from the repo https://github.com/tesseract2048/pvpgn.
Also this D2GS has different settings in the Windows registry unlike default D2GS.

But I just modified a file * .bin (runes.bin) in the patch, the rest it's all original.

How then proceed to run D2GS? Would help me?

4

Re: D2GS DROP PROBLEM

All D2GS versions by Marsgod that are in Magic Builder are prone to vulnerability and it can be crashed remotely by sending a special packet. Except multithreaded D2GS by tesseract, because all the packets are handled by proxy before directing to game engine.

It looks like your server s icrashed by the exploit (similar errors and exceptions).
The solution is to wait while Marsgod will fix the bug. Or use D2GS by tesseract (I'm not sure did you really use it or not).

Do not ask for support in PM.

5

Re: D2GS DROP PROBLEM

HarpyWar wrote:

All D2GS versions by Marsgod that are in Magic Builder are prone to vulnerability and it can be crashed remotely by sending a special packet. Except multithreaded D2GS by tesseract, because all the packets are handled by proxy before directing to game engine.

It looks like your server s icrashed by the exploit (similar errors and exceptions).
The solution is to wait while Marsgod will fix the bug. Or use D2GS by tesseract (I'm not sure did you really use it or not).

I understand ... I tried to use the D2GS Multithreaded Game Server for Diablo II 1.13c (Magic Builder) but when I try to run D2GS.exe he does not run, and neither generates log's to be able to identify why not this running.

What can it be?

6

Re: D2GS DROP PROBLEM

https://github.com/pvpgn/pvpgn-magic-builder/issues/17

As I said before it uses another registry path. "D2GS13" instead of "D2GS". Read deployment section of readme https://github.com/tesseract2048/d2gs

Do not ask for support in PM.

7 (edited by blackwolf 17.07.2016 05:31)

Re: D2GS DROP PROBLEM

I'm using a version of D2GS (marsgod) prone to vulnerability, crashing when someone sends a special package. (Crash all games, drop D2GS)

I can not make the construction of D2CS + D2GS (Multithreaded and D2CS by tesseract) to avoid this vulnerability problem, because I have no knowledge of C ++.

I've tried everything to get, but to no avail!

Could you provide me with a solution?
Enable version check in bnetd.ini to avoid another patch?
Enable the warden in d2gs to kill the game When sending a special packet?

I do not know what to do to resolve the situation ...   sad  sad

8

Re: D2GS DROP PROBLEM

I'm using a version of D2GS (marsgod) prone to vulnerability, crashing when someone sends a special package. (Crash all games, drop D2GS)

I can not make the construction of D2CS + D2GS (Multithreaded and D2CS by tesseract) to avoid this vulnerability problem, because I have no knowledge of C ++.

I've tried everything to get, but to no avail!

Could someone provide me with a solution?
Enable version check in bnetd.ini to avoid another patch?
Enable the warden in d2gs to kill the game When sending a special packet?

I do not know what to do to resolve the situation ...   sad  sad

9

Re: D2GS DROP PROBLEM

https://github.com/tesseract2048/pvpgn/ … t-87667695

Harpy, tesseract said that your builds are more up to date..
So those versions of d2gs and d2cs Multithreaded aren't stable to go live?

10

Re: D2GS DROP PROBLEM

He means that PvPGN is up to date.
But his D2GS is only working with his modified D2CS. It should be stable since it's working in production (he wrote in readme of the project about it).

So, you can use our PvPGN, but you must use his D2CS to make it working with his D2GS.

https://github.com/pvpgn/pvpgn-magic-builder/issues/17

Do not ask for support in PM.

11

Re: D2GS DROP PROBLEM

It was then that I stopped ... because I can not build D2CS for this D2GS MT  sad  sad

12

Re: D2GS DROP PROBLEM

Now you can run it on Linux. Any low cost VDS will be enough for D2CS.

Do not ask for support in PM.

Posts: 12

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] Diablo → D2GS DROP PROBLEM



Generated in 0.118 seconds (80% PHP - 20% DB) with 20 queries