Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Warcraft → Anonymous Games not working

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 4

1

Topic: Anonymous Games not working

Hi I just installed the server, I dont know if this is right out of the box. But when I try to start a 1v1 game with a friend and click the sword to match a game, I got a game found message but then game doesnt load and I get this message:

Unable to connect the game.

This can happen due to a loss of network connectivity...

Here's the bnet log:

Jul 18 01:31:12 [trace] _anongame_match: [23] matching started for level 0 player in queue 0
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 0 players
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 1 players
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 2 players
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 3 players
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 4 players
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 5 players
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 6 players
Jul 18 01:31:12 [trace] _anongame_match: [23] Matching finished, not enough players (found 1)
Jul 18 01:31:12 [trace] _anongame_match: [22] matching started for level 0 player in queue 0
Jul 18 01:31:12 [trace] _anongame_match: Traversing level 0 players
Jul 18 01:31:12 [trace] anongame_unqueue: unqueued player [23] level 0
Jul 18 01:31:12 [trace] anongame_unqueue: unqueued player [22] level 0
Jul 18 01:31:12 [trace] _get_map_from_prefs: got map Maps\FrozenThrone\(4)CentaurGrove.w3x from prefs
Jul 18 01:31:12 [debug] trans_net: checking 0.0.0.0:6200 for client 191.177.185.158 ...
Jul 18 01:31:12 [debug] trans_net: no match found for 0.0.0.0:6200 (not translated)
Jul 18 01:31:12 [debug] trans_net: checking 0.0.0.0:6200 for client 191.177.185.158 ...
Jul 18 01:31:12 [debug] trans_net: no match found for 0.0.0.0:6200 (not translated)

2

Re: Anonymous Games not working

It should be a problem in a connectivity between you and your friend. Because pvpgn only connects both players and one of them become a game host.
Try create a custom game, when you a host and another case when your friend a host, You will see can you play or not.

Ghost bot can solve the problem. But not for quick match (sword button), only for custom games.

Do not ask for support in PM.

3 (edited by slaklad 18.07.2017 21:05)

Re: Anonymous Games not working

Thanks HarpyWar,

You mean if any of the users can host a game then quick match will work right away?

If this is the case then it's bugged my friend could host and even host custom games so we played yesterday. But when we start a quick match it always returned the errors above.

What is required to make quick match work? By making work I mean the games to be hosted by server not one of players. I know you are very experienced programmer and you know what's required.

Tell me and maybe I can find good people to help. I am a very influent person.

4

Re: Anonymous Games not working

I didn't write this part of code or examine it so closer to affirm this. So this is only my assumption and I may be wrong.
For now I can't tell more about this, or fix in code something related.

Someone should go deeper and make comprehensive testing.

Добавлено: 19.07.2017 11:40

Port 6112 should be opened on both sides, player-host could be chosen randomly
https://github.com/pvpgn/pvpgn-server/i … -316304901

So check that you also can host a custom game.

Do not ask for support in PM.

Posts: 4

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] Warcraft → Anonymous Games not working



Generated in 0.073 seconds (84% PHP - 16% DB) with 20 queries