Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Tech Support → Problem with verification version check d2 patch 1.13c

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 2

1 (edited by skatte 15.10.2017 20:18)

Topic: Problem with verification version check d2 patch 1.13c

Hi all, I have only problem with patch verification for d2lod 1.13c

PvPGN 1.99.7
D2GS 1.13c

Log by PvPGN

Oct 15 18:10:22 [debug] pvpgn::bnetd::ipbanlist_check: lastcheck: 1508083044, now: 1508083822, now-lc: 778.
Oct 15 18:10:22 [debug] pvpgn::bnetd::ipbanlist_check: checking 127.0.0.1
Oct 15 18:10:22 [info ] pvpgn::bnetd::sd_accept: [600] accepted connection from 127.0.0.1:50251 on 0.0.0.0:6112
Oct 15 18:10:23 [info ] pvpgn::bnetd::conn_create: [600][568] sessionkey=0x1508108975 sessionnum=0x00000002
Oct 15 18:10:23 [debug] pvpgn::bnetd::sd_accept: [600] client connected to a bnet listening address
Oct 15 18:10:23 [info ] pvpgn::bnetd::handle_init_packet: [600] client initiated bnet connection
Oct 15 18:10:23 [trace] pvpgn::bnetd::conn_shutdown: [600] connection already closed
Oct 15 18:10:23 [debug] pvpgn::bnetd::conn_set_class: added latency check timer
Oct 15 18:10:23 [debug] pvpgn::bnetd::handle_udp_packet: [568] got UDPTEST packet from 127.0.0.1:6112 (myself?)
Oct 15 18:10:23 [debug] pvpgn::bnetd::handle_udp_packet: [568] got UDPTEST packet from 127.0.0.1:6112 (myself?)
Oct 15 18:10:23 [debug] pvpgn::bnetd::_client_countryinfo109: [600] COUNTRYINFO_109 packet tzbias=0xffffff88 lcid=1045 langid=1033 arch="IX86" client="D2XP" versionid=0x0000000d gamelang="plPL"
Oct 15 18:10:23 [debug] pvpgn::bnetd::_client_countryinfo109: [600] COUNTRYINFO_109 packet from "Poland" "POL"
Oct 15 18:10:23 [info ] pvpgn::bnetd::conn_set_archtag: [600] setting client arch to "IX86"
Oct 15 18:10:23 [info ] pvpgn::bnetd::conn_set_clienttag: [600] setting client type to "D2XP"
Oct 15 18:10:23 [info ] pvpgn::bnetd::conn_set_gamelang: [600] setting client gamelang to "plPL"
Oct 15 18:10:23 [debug] pvpgn::bnetd::_client_countryinfo109: [600] selecting version check
Oct 15 18:10:23 [debug] pvpgn::bnetd::versioncheck_create: version check entry archtag=IX86, clienttag=W3XP
Oct 15 18:10:23 [debug] pvpgn::bnetd::versioncheck_create: version check entry archtag=IX86, clienttag=W3XP
Oct 15 18:10:23 [debug] pvpgn::bnetd::versioncheck_create: version check entry archtag=IX86, clienttag=D2XP
Oct 15 18:10:23 [debug] pvpgn::bnetd::_client_countryinfo109: [600] selected "ver-IX86-1.mpq" "A=3845581634 B=880823580 C=1363937103 4 A=A-S B=B-C C=C-A A=A-B"
Oct 15 18:10:23 [info ] pvpgn::bnetd::_client_authreq109: [600] CLIENT_AUTHREQ_109 ticks=0x75b13cf2, verstr=1.0.13.0 exeinfo="Game.exe 03/09/10 04:10:51 61440" versionid=0x0000000d gameversion=0x01000d00 checksum=0x7686beca
Oct 15 18:10:23 [info ] pvpgn::bnetd::versioncheck_validate: no match in list, setting to: D2XP
Oct 15 18:10:23 [info ] pvpgn::bnetd::_client_authreq109: [600] unable to test client (closing connection)
Oct 15 18:10:23 [info ] pvpgn::bnetd::_client_authreq109: [600] client matches versiontag "D2XP"
Oct 15 18:10:23 [debug] pvpgn::bnetd::sd_tcpinput: [600] read returned -1 (closing connection)
Oct 15 18:10:23 [info ] pvpgn::bnetd::conn_destroy: [600] closed bnet connection

Bnetd.conf

# If you disable this you must have one or more of the MPQ files.  Otherwise
# clients will hang when they first connect because they are attempting to
# download them.  The versioncheck can only be skipped for clients older
# than 109.  Starting with version 109 the clients will always do version
# checking since they do not function properly if the server does not
# request it.
skip_versioncheck = false

# If you enable the version checks but want to allow clients that don't pass
# the checksum test then enable this.
allow_bad_version = true

# If you enable the version checks but want to allow clients that aren't
# listed in the versioncheck configuration file then enable this.  Unless
# you have a very complete file or are very paranoid about cheaters this
# is a good idea.
allow_unknown_version = false

Versioncheck.conf

# Diablo II - LoD (Expansion) 1.13c
"A=3845581634 B=880823580 C=1363937103 4 A=A-S B=B-C C=C-A A=A-B" \
IX86ver1.mpq \
IX86 \
D2XP \
"Game.exe 03/09/10 04:10:51 61440" \
0x0000000d \
1.0.13.0 \
0x7686beca \
D2XP_113C

The problem does not occur with versions 1.14a, 1.14b, 1.14c and 1.14d
Does anyone know how to solve this problem?

2

Re: Problem with verification version check d2 patch 1.13c

try changing to "false" this option..

# If you enable the version checks but want to allow clients that don't pass
# the checksum test then enable this.
allow_bad_version = false

Added: 15.10.2017 23:12

Briefly, this option asks whether you want to allow other versions to connect to your server.

Posts: 2

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] Tech Support → Problem with verification version check d2 patch 1.13c



Generated in 0.061 seconds (83% PHP - 17% DB) with 20 queries