Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Diablo → How to force update upon connecting to server.

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 6

1

Topic: How to force update upon connecting to server.

Hi to everyone!

My problem is that when im connecting to my server it detects that I am running an older version that 1.14d and doesn't update my client but in the PvPGN window shows that there is an upgrade available for my client. I created entries in autoupdate.conf to update ALL clients (D2DV, D2XP) to 1.14d and placed files in files folder (D2DV_IX86_1xx_114D.mpq, D2XP_IX86_1xx_114D.mpq).

Here's my D2 section of my autoupdate.conf file:

==================== Diablo II Expansion (LoD) ===========================
# Note: the following assumes that you want to upgrade all Diablo II clients
# to version 1.13c.  If you are still running a 1.10 or 1.09d realm, you
# will need to modify these entries accordingly.

IX86    D2XP    D2XP_107        D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_108        D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_109        D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_109B       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_109C       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_109D       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_110        D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_111        D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_112A       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_113C       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_113D       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_114A       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_114B       D2XP_IX86_1xx_114D.mpq
IX86    D2XP    D2XP_114C       D2XP_IX86_1xx_114D.mpq


# ========================== Diablo II (DV) =================================
# Note: the following assumes that you want to upgrade all Diablo II clients
# to version 1.13c.  If you are still running a 1.10 or 1.09d realm, you
# will need to modify these entries accordingly.

IX86    D2DV    D2DV_100        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_101        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_103        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_104B       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_104C       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_105        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_105B       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_106        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_106B       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_108        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_109        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_109B       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_109C       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_109D       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_110        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_111        D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2DV_112A       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2XP_113C       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2XP_113D       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2XP_114A       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2XP_114B       D2DV_IX86_1xx_114D.mpq
IX86    D2DV    D2XP_114C       D2DV_IX86_1xx_114D.mpq

Extra: Some people was looking for 1.13c autoupdate MPQ file and can't download it with bnftp because Blizzard took down the files long ago. Here is it for everyone (D2DV, D2XP): www.mediafire.com/file/9a7ado63cie7lm8

Feel free to share my link with others ;)

Thank you very much in advance.

Added: 20.08.2018 00:35

I forgot to post my PvPGN version:

2

Re: How to force update upon connecting to server.

I have seen other forum users try to use this feature of PvPGN without success.

If you can post here how did you solve your problem please.

3

Re: How to force update upon connecting to server.

Feofilaktt wrote:

I have seen other forum users try to use this feature of PvPGN without success.

If you can post here how did you solve your problem please.

I can't fix it. I don't know how. There isn't

skip_versioncheck

in my .conf files. Did they moved this option in this version to other file?

4

Re: How to force update upon connecting to server.

dahang_95 wrote:

in my .conf files. Did they moved this option in this version to other file?

Yes, they removed this setting in version PvPGN 1.99.7.1.0-PRO. (link)

Removed skip_versioncheck, version_exeinfo_match, and version_exeinfo_maxdiff options

But I did not understand where you would use this function to solve your problem.

Explain it better so I can help you.

5 (edited by dahang_95 31.08.2018 03:35)

Re: How to force update upon connecting to server.

Feofilaktt wrote:

Explain it better so I can help you.

When that option (skip_versioncheck) is enabled, PvPGN checks version of the game when you connect to the server. If it is disabled, you can connect with any version, of course you need the corresponding entries in "versioncheck.json" anyways because PvPGN needs to identify which game client is logging (D2DV, D2XP, WAR3, W3XP, etc)

It works like that or am I wrong?

6

Re: How to force update upon connecting to server.

Im doing some research with PvPGN 1.8.0 RC2. The autoupdate feature works perfect in this version.
I think when the developers removed "skip_versioncheck", they broke the autoupdate feature.

Posts: 6

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] Diablo → How to force update upon connecting to server.