Skip to forum content

You are not logged in. Please login or register.


[ Closed ]

forums.pvpgn.pro → [RU] Starcraft → [Solved] Starcraft versioncheck

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 2

1

Topic: [Solved] Starcraft versioncheck

Установил сервер PvPGN версия 1.8.2, все работает исправно, работают игры Diablo II ver. 1.11b (последний патч), Warcraft III ver. 1.21 (последний патч), а вот Starcraft не хочет работать с последним патчем (1.15.1 либо 1.15.2) - работает только с патчем версии 1.14, хотя в файле versioncheck.conf (необходимый для проверки версии игры клиента) написано:

# Starcraft - Broodwar (Expansion) 1.15.1 - (Broodwar mode)
# Starcraft - Broodwar (Expansion) 1.15.1 - (Starcraft mode)

Стало быть версия клиента 1.15.1 поддерживается сервером, но при подключении к серверу PvPGN такого клиента, сервер отправляет его куда подальше, якобы с неопознанной версией клиента и просьбой связаться с саппортом батл.нета. Пробовал различные лоадеры, также пробовал сборку от harpywar'a - не помогло sad Есть идеи доктор?

Не пускайте детей в интернет, интернет от этого тупеет.

2

Re: [Solved] Starcraft versioncheck

Блин, какая досадная ошибка sad
Вот говорила же мне мама: "Читай мануалы ВНИМАТЕЛЬНО"
Открываем файл /conf/bnetd.conf и изменяем:

allow_bad_version = false

на

allow_bad_version = true

После этих манипуляций наш сервер проверяет версию клиента, НО пропускает его если версия не является "правильной" (не поддерживаемой сервером)

P.S. кстати starcraft с версией 1.15.2 сервер "проглотил" на ура.
Тему можно закрывать. wink

Не пускайте детей в интернет, интернет от этого тупеет.

Posts: 2

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [RU] Starcraft → [Solved] Starcraft versioncheck



Generated in 0.052 seconds (78% PHP - 22% DB) with 21 queries