Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Tech Support → WC3 Unable to join games

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 1

1 (edited by pifipepo 08.11.2018 22:01)

Topic: WC3 Unable to join games

Im having troubles to join games and my friends on the external network has same issue. They can log in to a server but if someone creates new game, we can see it on the list, but no one can join it. I tried even with 2 clinets from my own network. I have ports forwarded, no changes were made to address_translation.conf, even on default settings no one can join.

Ports I have forwarded:
6112 to 6119,4000,6200

All ports default

My setup is:   Internet -> first router ->second router ->pc with the server on
Internet dynamic IP -> 172.20.0.1 network -> 192.168.1.1 network -> 192.168.1.20 my pc ip, static [tried with two clients on my pc, one on virtual machine with ip of 192.168.20.20)
Ports are open on 192.168.1.1 network, 172.20.0.1 network is bridge, and it works because I can host games on official battle net or other services work great.

The log when trying to join is:
Nov 08 16:30:00 [info ] handle_bnet: Told Mutual Friends your in game test
Nov 08 16:30:00 [debug] pvpgn::bnetd::_client_startgame4: [632] got startgame4 status for game "test" is 0x00000010 (gametype=0xc009 option=0x0042, flag=0x0000)
Nov 08 16:30:00 [info ] pvpgn::bnetd::game_create: game "test" (pass "") type 1(UNKNOWN) startver 4 created
Nov 08 16:30:06 [info ] pvpgn::bnetd::_client_anongame_cancel: [624] got FINDANONGAME CANCEL packet
Nov 08 16:30:06 [trace] pvpgn::bnetd::anongame_unqueue: unqueued player [624] level 0
Nov 08 16:30:10 [debug] pvpgn::bnetd::_client_gamelistreq: GAMELISTREPLY looking for public games tag="W3XP" bngtype=0x0000e000 gtype=all
Nov 08 16:30:10 [debug] pvpgn::bnetd::_glist_cb: [624] considering listing game="test", pass="" clienttag="W3XP" gtype=1
Nov 08 16:30:10 [debug] pvpgn::trans_net: checking 172.20.0.1:6112 for client 172.20.0.1 ...
Nov 08 16:30:10 [debug] pvpgn::trans_net: no match found for 172.20.0.1:6112 (not translated)
Nov 08 16:30:10 [debug] pvpgn::bnetd::_client_gamelistreq: [624] GAMELISTREPLY sent 1 of 1 games

Which makes me think there might be a need of editing address_translation.conf as it uses my first router internal IP... but how would I go about it?

This issue also might be disabling my 'ladder matchmaking' as it finds no players.

Edit: even if i try to host with Ghost++, it connect to the realm, hosts a game but I can not join it. All on local pc, but this time game is not shown on the list so i enter its name by mysself. When trying on official battlenet, it works. Of course i change game version, point to the right wc3 directory etc

Added: 09.11.2018 18:25

tldr; how would I go of hosting pvpgn on my machine and also running ghost++ and my own WC3 client on my machine and let others on external network to join my games, let me to join theirs and also to let me to join a game hosted by my own bot. Im nearly sure it is something to do with adres translation.

Posts: 1

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] Tech Support → WC3 Unable to join games



Generated in 0.073 seconds (78% PHP - 22% DB) with 20 queries