Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Tech Support → Simply cannot seem to get a server live

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 8

1 (edited by tmuhlhausen 11.01.2020 07:16)

Topic: Simply cannot seem to get a server live

For three weeks now i have configured and reconfigured multiple instances of both PVPGN servers and D2GS and cannot seem to understand where i am going wrong, i am almost certain i have them running currently as i run nmap and it can see the telnet port as well as 6112, the gateway changer also detects its live, all ports have been forwarded properly as far as i can tell, the one thing i do however notice is d2gs is making empty logs, and there is no other sign of error is any file suggesting anything is wrong. all 3 servers are interacting but  im certain at this point there is something wrong with d2gs but from my experience i shouldnt even need it active to connect to to char serv and bnet serv no?, nmap is not able to see port 4000 open(i think it just isnt being broadcasted on) but it is on the same rule as port 6112. when i disable, then re-enable them. I clearly see they are both being opened and closed. thing i dont really understand is nmap being able to see 6112 open, the gateway editor can also detect the server but my client just hangs. any help would be greatly appreciated, can also try to provide more info just want to keep it as simple as possible.


Ive Attempted this many times before as well,even understand the basic networking principles, but theres something up anyways

2

Re: Simply cannot seem to get a server live

You need to allow outbound traffic on the server except for ports you don't want traffic to like 23 with your firewall. use either windows or 3rd party firewall. Also need to allow outbound traffic on your client computer. If you can't reach it with nmap from the remote the traffic is being blocked some where..

On the server you can look for open server ports like so.  My setup is for LAN only traffic without port forwarding.

C:\netstat -oan

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP    0.0.0.0:4000           0.0.0.0:0              LISTENING       580
  TCP    0.0.0.0:8888           0.0.0.0:0              LISTENING       580
  TCP    192.168.1.133:6112     0.0.0.0:0              LISTENING       1836
  TCP    192.168.1.133:6113     0.0.0.0:0              LISTENING       1392
  TCP    192.168.1.133:6114     0.0.0.0:0              LISTENING       1404
  TCP    192.168.1.133:6200     0.0.0.0:0              LISTENING       1836
  UDP    192.168.1.133:6112     *:*                                    1836   

3 (edited by tmuhlhausen 11.01.2020 10:03)

Re: Simply cannot seem to get a server live

i know that helped a bit because 6113-6114 are visable now. i am copying over a gameserver i had running on another pc to see if it runs on this server machine. i am thinking it might have something todo with permissions ill debug a bit more here actually get D2GS to show on port 4000. thanks, By the way

Added: 11.01.2020 02:02

So D2GS is spitting out empty logs and asking for registry access, when i previously tried to enable it to have registry access, i failed a lot

4

Re: Simply cannot seem to get a server live

So you can successfully log into PvPGN/BNET now? D2GS is always another headache but if you can get connected to that, that's the first step complete.

Admin of SlashDiablo - Large vanilla-like server
Founder of Diablo2.org - Dedicated Discord server for PvPGN/D2GS questions

5 (edited by tmuhlhausen 12.01.2020 19:35)

Re: Simply cannot seem to get a server live

Thanks for the reply, No havent been able to but im damn sure the vpvgn servers are running, and yeah like you say if i cant connect to the 3 servers which are talking to each other (not the game server). Then the issue lie's in my port setup or something. gateway always can be detected is what i don't understand but it seems only port 6112 is viewable with nmap, should 6112-6114 all be showing, plus port 4000?


Also.. nmap seems to trigger handle_packet_init errors so its able to get through hmm im about to see if i can telnet in

6

Re: Simply cannot seem to get a server live

I've installed PvPGN like 4 times on different OS's now, I'm preparing a new walk through on installing it for a LAN only setup.

I think this has something to do with the issue, because its gotten me twice already In Win7 and Win10 setups. Private networks are not connected in windows firewall.


https://forums.pvpgn.pro/uploads/images/2020/01/12/localnotconnected.jpg

7

Re: Simply cannot seem to get a server live

I have allowed all rules for both public and private networks but i did try what you suggested and same issue, i can detect with gateway editor but cant get to the login screen using the client

8

Re: Simply cannot seem to get a server live

had nothing todo with ports by the way... turns out it was just my error using the wrong version of files in the game server

Posts: 8

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [EN] Tech Support → Simply cannot seem to get a server live