Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [RU] Tech Support → [Solved] Пускать только нужные версии

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 10

1

Topic: [Solved] Пускать только нужные версии

Можно ли сделать сабж? Есть конечно вариант удалить все ненужные версии из versioncheck.conf, но он мне особо изящным не кажется. Просто обновить versioncheck.conf при выходе новой версии не удастся.
Нельзя ли где-то в конфигах написать "пускать стар ver.>= 1.15"?

2

Re: [Solved] Пускать только нужные версии

В bnetd.conf  поставь значения:

skip_versioncheck = false - заставит обязательно проверять версию клиента.
allow_bad_version = false - если версия клиента не указана в versioncheck.conf, отправляет клиента ф топку.
allow_unknown_version = false - если серв не может получить версию клиента, отправляет ф топку.

Не пускайте детей в интернет, интернет от этого тупеет.

3

Re: [Solved] Пускать только нужные версии

Sere}l{ka, вы не отвечаете на мой ответ! smile

Смысл моего поста в том, можно ли это сделать, не удаляя старые версии из versioncheck.conf

4

Re: [Solved] Пускать только нужные версии

Тоесть ты хочешь пускать на сервер клиентов с новой версией, но не изменять файл versioncheck.conf? Так не получится, тем более что в новых ревах versioncheck.conf уже подправлен, добавлены новые версии клиентов + фикс для Vista (Vista висла, Vista виснет, Vista будет виснуть)
Я ответил на твой ответ? smile

Не пускайте детей в интернет, интернет от этого тупеет.

5

Re: [Solved] Пускать только нужные версии

Новые версии стара не редко ли выходят?
xpeh, как ты хочешь сделать нельзя.

Do not ask for support in PM.

6

Re: [Solved] Пускать только нужные версии

Ну редко-нередко, но решение через жопу, вы согласны?

7

Re: [Solved] Пускать только нужные версии

Пожалуй нет, нормальное решение, разрешать версии клиентов ч помошью конфига  - versioncheck.conf.
Есть предложение лучше?

Не пускайте детей в интернет, интернет от этого тупеет.

8 (edited by xpeh 30.06.2008 06:54)

Re: [Solved] Пускать только нужные версии

Sere}l{ka
это и был мой вопрос.

Нет ли варианта получше?

9

Re: [Solved] Пускать только нужные версии

На сколько мне известно - нет.

Не пускайте детей в интернет, интернет от этого тупеет.

10

Re: [Solved] Пускать только нужные версии

В общем, есть 2 варианта:
- Оставить в versioncheck.conf только желаемые версии. Старым версиям будет выдаваться unknown version, virus blablabla, что есть минус.
- Оставить versioncheck.conf в покое и настроить autoupdate.conf. Ахтунг! Прописывать апдейты для всех версий (лучше по маске), вполне спокойно может заявиться чудо с версией 1.01 и спрашивать в чате "а почему поиграть не получается?". Юзерам с кривым инсталлом, как и раньше, будет писаться про вирус.

Posts: 10

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 1 guest, 0 registered users

forums.pvpgn.pro → [RU] Tech Support → [Solved] Пускать только нужные версии



Generated in 0.086 seconds (81% PHP - 19% DB) with 20 queries