Skip to forum content

You are not logged in. Please login or register.


forums.pvpgn.pro → [EN] Tech Support → Starcraft - External and Internal Clients can't connect game

Pages 1

You must login or register to post a reply

RSS topic feed

Posts: 4

1

Topic: Starcraft - External and Internal Clients can't connect game

I'm pretty sure this is related to how I have the network translation file setup and was wondering if someone could help me diagnose.

Basically the topic is the correct. I can get the External Client and Internal Client to both login to Battle.net for starcraft, chat with each other, but when one creates a game and the other tries to join, it times stating the lag time is too great.... but I'm sure that's not the case.

Pretty Sure my network translation file may need some tweaking. Could someone please take a look at the following settings and see if I'm missing something, have something configured wrong?

# w3route server ip translation
# input (ip:port)   output (ip:port)   exclude (ip/netmask)    include (ip/netmask)
#----------------- ------------------ ----------------------  ----------------------

# Example, if you left w3route = 0.0.0.0:6200 as it is by default in bnetd.conf
# AND you have the external IP 1.2.3.4 AND you want to exclude from translation 
# the internal W3 clients (those with IPs 192.168.0.x) AND you port forward 
# port 6200 TCP from your router to the pvpgn server port 6200 then here put:

192.168.3.110:6200      XX.XXX.XXX.XXX:6200      NONE           ANY

###############################################################################
# Game Translations for clients/games (client data ports)
#
# You need this ONLY if you will have internal players that want to play with 
# external ones.
#
# This setting is NOT NEEDED for D2 closed realm clients (they connect to d2gs 
# to play games not to eachover).
#
# Set input address to the client to be translated 
# Set output address to the address to be sent to the other clients 
# Set exclude to the range of clients you want to receive the input address 
#    instead of the output address 
# Set include to the range of clients you want to receive the output address 
#
# input (ip:port)    output (ip:port)    exclude (ip/netmask)    include (ip/netmask)
#-----------------  ------------------  ----------------------  ----------------------

# Example, if you have an internal client on IP 192.168.1.10 AND you have the 
# external IP 1.2.3.4 AND you want to exclude from translation the internal 
# clients (those with IPs 192.168.1.x and 10.x.y.z) AND you port forward 
# port 6118 TCP AND UDP from your router to the client IP and port 6112 then 
# here put:

192.168.3.143:16112   XXX.XXX.XXX.XXX:16112      NONE  ANY

################################################################################
# Diablo II Character Server translation (d2cs)
#
# You need this ONLY if you run a d2cs (ie ONLY if you will host a Diablo2 
# closed realm).
#
# Set input address to the ip of d2cs (same as the ip in the realm.conf)
# Set output address to the address to be sent to the clients
# Set exclude to the range of clients you want to receive the input address
#    instead of the output address
# Set include to the range of client you want to receive the output address
#
# input (ip:port)    output (ip:port)    exclude (ip/netmask)    include (ip/netmask)
#-----------------  ------------------  ----------------------  ----------------------

# Example, if you run a d2cs on IP 192.168.1.10 port 6113 and you have put the 
# same IP/port in realm.conf AND you have the external IP 1.2.3.4 AND you want 
# to exclude from translation the internal clients (those with IPs 192.168.1.x) 
# AND you port forward port 6113 TCP from your router to the machine running 
# d2cs and port 6113 then here put:

192.168.3.110:6113   XXX.XXX.XXX.XXX:6113       NONE          ANY

################################################################################
# Diablo II Game Server Translation (d2gs)
#
# Set input address to the ip of d2gs (same as the gameservlist in d2cs.conf)
# Set output address to the address to be sent to the clients
# Set exclude to the range of clients you want to receive the input address
#    instead of the output address
# Set include to the range of client you want to receive the output address
#
# input (ip:port)    output (ip:port)    exclude (ip/netmask)    include (ip/netmask)
#-----------------  ------------------  ----------------------  ----------------------

# Example, if you run a d2gs on IP 192.168.1.100 (and port 4000, d2gs cannot 
# listen on other port, it will automatically listen on port 4000) and you have 
# put the same IP in d2cs.conf and d2dbs.conf gameservlist setting AND you have 
# the external IP 1.2.3.4 AND you dont want to exclude from translation anyone 
# AND you port forward port 4000 TCP from your router to the machine running 
# d2gs and port 4000 then here put:

192.168.3.110:4000  XXX.XXX.XXX.XXX:4000       NONE                    ANY



################################################################################
# Westwood Online Game Server Translation (wwol)
#
#
# input (ip:port)    output (ip:port)    exclude (ip/netmask)    include (ip/netmask)
#-----------------  ------------------  ----------------------  ----------------------

192.168.3.110:4005   XXX.XXX.XXX.XXX:4005       NONE          ANY

2

Re: Starcraft - External and Internal Clients can't connect game

check it

Added: 21.02.2022 08:37

check it the bold words
# Example, if you have an internal client on IP 192.168.1.10 AND you have the
# external IP 1.2.3.4 AND you want to exclude from translation the internal
# clients (those with IPs 192.168.1.x and 10.x.y.z) AND you port forward
# port 6118 TCP AND UDP from your router to the client IP and port 6112 then
# here put:

192.168.3.143:16112   XXX.XXX.XXX.XXX:16112      NONE  ANY

3

Re: Starcraft - External and Internal Clients can't connect game

394719209 wrote:

check it

Added: 21.02.2022 08:37

check it the bold words
# Example, if you have an internal client on IP 192.168.1.10 AND you have the
# external IP 1.2.3.4 AND you want to exclude from translation the internal
# clients (those with IPs 192.168.1.x and 10.x.y.z) AND you port forward
# port 6118 TCP AND UDP from your router to the client IP and port 6112 then
# here put:

192.168.3.143:16112   XXX.XXX.XXX.XXX:16112      NONE  ANY

Negative - I tried changing this to:

192.168.3.1.143:6112 xxx.xxx.xxx.xxx:6112 NONE ANY

Still doesn't work. Same issue.

4 (edited by Feofilaktt 27.02.2022 13:50)

Re: Starcraft - External and Internal Clients can't connect game

justaplaneguy wrote:

Negative - I tried changing this to:

192.168.3.1.143:6112 xxx.xxx.xxx.xxx:6112 NONE ANY

Still doesn't work. Same issue.

The IP:Port is still wrong...

192.168.3.1.143:6112

The correct:
192.168.3.143:6112

If it still doesn't work, configure the output with the IP as well and check that your computer/router firewall is not blocking the necessary ports.

Diablo 2 Online

ItemWizard - Rank - Armory - Market - Clans - Builds

Posts: 4

Pages 1

You must login or register to post a reply

Who now at forum

Currently view post: 0 guests, 0 registered users

forums.pvpgn.pro → [EN] Tech Support → Starcraft - External and Internal Clients can't connect game